NetBSD/xsrc tsNXxIsexternal/mit/xf86-video-intel/dist configure ltmain.sh, external/mit/xf86-video-intel/dist/m4 libtool.m4

   fix merge botches.

   re-add files autoconf files that the build sort of needs at
   least configure for.  command used:

     % cd /usr/xsrc/external/mit/xf86-video-intel/dist
     % autoreconf -I m4 -I /usr/xsrc/external/mit/xorg-server/dist -i

   tested on sandy bridge and kaby lake.

NetBSD/xsrc rasnfrNexternal/mit/xf86-video-intel/dist/src/sna sna_display.c sna_dri2.c, external/mit/xf86-video-intel/dist/src/uxa intel_display.c

   merge xf86-video-intel 6afed33b2d673d88674f0c76efe500ae414e8e1b.

NetBSD/xsrc Z2Tqt8Oexternal/mit/xf86-video-intel/dist/src/sna gen9_render.c sna_display.c, external/mit/xf86-video-intel/dist/test present-test.c

   initial import of xf86-video-intel git version 6afed33b2d673d88674f0c76efe500ae414e8e1b

NetBSD/xsrc qBSujurexternal/mit/imake/dist compile README, external/mit/imake/include config.h

   merge imake 1.0.8.

NetBSD/xsrc onkPIEUexternal/mit/imake/dist config.guess aclocal.m4

   initial import of imake-1.0.8

NetBSD/xsrc S81DX4dexternal/mit/makedepend/dist README, external/mit/x11perf/dist README

   merge makedepend 1.0.6 and x11perf 1.6.1.

NetBSD/xsrc 3MWA1Dxexternal/mit/x11perf/dist aclocal.m4 config.guess, external/mit/x11perf/dist/man x11perf.man

   initial import of x11perf-1.6.1

NetBSD/xsrc 1NtT7TSexternal/mit/makedepend/dist aclocal.m4 config.guess

   initial import of makedepend-1.0.6

NetBSD/xsrc GI4H7ERexternal/mit/libXvMC/dist README, external/mit/libXvMC/dist/src XvMC.c

   merge libXvMC 1.0.11, libXxf86dga 1.1.5, libxkbfile 1.1.0, and xtrans 1.4.0.

NetBSD/xsrc ep8n5K2external/mit/xtrans/dist aclocal.m4 config.guess

   initial import of xtrans-1.4.0

NetBSD/xsrc 5xnwxbsexternal/mit/libxkbfile/dist aclocal.m4 ltmain.sh, external/mit/libxkbfile/dist/include/X11/extensions XKMformat.h

   initial import of libxkbfile-1.1.0

NetBSD/xsrc HKIkLUDexternal/mit/libXxf86dga/dist aclocal.m4 ltmain.sh

   initial import of libXxf86dga-1.1.5

NetBSD/xsrc mcf6MS0external/mit/libXvMC/dist aclocal.m4 ltmain.sh

   initial import of libXvMC-1.0.11

NetBSD/xsrc QI6dOTbexternal/mit/libXdmcp/dist README, external/mit/libXft/dist README

   merge libXdmcp 1.1.3, libXext 1.3.4, libXft 2.3.3, libXmu 1.1.3 and
   libXrandr 1.5.2.

NetBSD/xsrc ds3xUCMexternal/mit/libXrandr/dist aclocal.m4 ltmain.sh

   initial import of libXrandr-1.5.2

NetBSD/xsrc 48XEMgKexternal/mit/libXmu/dist aclocal.m4 ltmain.sh

   initial import of libXmu-1.1.3

NetBSD/xsrc MvJimzeexternal/mit/libXft/dist aclocal.m4 ltmain.sh

   initial import of libXft-2.3.3

NetBSD/xsrc atgYWQIexternal/mit/libXext/dist aclocal.m4 ltmain.sh, external/mit/libXext/dist/m4 libtool.m4 ltoptions.m4

   initial import of libXext-1.3.4

NetBSD/xsrc Y7nJ9Aqexternal/mit/libXdmcp/dist aclocal.m4 ltmain.sh

   initial import of libXdmcp-1.1.3

NetBSD/xsrc NefkB0gexternal/mit/xf86-video-intel/dist/src intel_list.h

   merge changes from xorg-server 1.20 list.h into this older version.

   fixes sandy bridge crashing problems for me.

NetBSD/xsrc DglwuE9external/mit/MesaLib.old/dist/src/mesa/drivers/dri/common xmlconfig.c, external/mit/MesaLib/dist/src/util u_process.c

   spell it defined(__NetBSD__) so it actually matches and we skip this
   pragma warning during the build:

   Warning: Per application configuration won't work with your OS version.

NetBSD/xsrc 5bt1iilexternal/mit/MesaLib/dist/src/mesa/main git_sha1.h, external/mit/MesaLib/src/mesa/main remap_helper.h

   remove files not wanted for mesa 18.

NetBSD/xsrc cMINuSHexternal/mit/mesa-demos/dist/src/egl/eglut eglut_screen.c, external/mit/mesa-demos/dist/src/egl/opengl demo2.c demo1.c

   merge mesa-demos 8.4.0.

NetBSD/xsrc EGIWeJDexternal/mit/mesa-demos/dist ltmain.sh configure, external/mit/mesa-demos/dist/m4 libtool.m4

   initial import of mesa-demos-8.4.0

NetBSD/xsrc CdCIl43external/mit/xfd/dist compile README, external/mit/xprop/dist README

   merge xfd 1.1.3 and xprop 1.2.4.

NetBSD/xsrc dpU44Utexternal/mit/xprop/dist ChangeLog configure

   initial import of xprop-1.2.4

NetBSD/xsrc 7cPUn7iexternal/mit/xfd/dist aclocal.m4 config.guess

   initial import of xfd-1.1.3

NetBSD/xsrc mmOxPkOexternal/mit/transset/dist configure aclocal.m4

   initial import of transset-1.0.2

NetBSD/xsrc 83NbCg5external/mit/libFS/dist README, external/mit/libFS/include config.h

   merge libFS 1.0.8, libXcomposite 0.4.5, and libXcursor 1.2.0.

NetBSD/xsrc MDIdKzDexternal/mit/libXcursor/dist config.guess config.sub

   initial import of libXcursor-1.2.0

NetBSD/xsrc xdrT071external/mit/libXcomposite/dist aclocal.m4 ltmain.sh

   initial import of libXcomposite-0.4.5

NetBSD/xsrc spJpRQdexternal/mit/libFS/dist aclocal.m4 ltmain.sh

   initial import of libFS-1.0.8

NetBSD/xsrc FiDv4vyexternal/mit/xinit/dist/man startx.man

   remove reference to non existance sys.startxrc.

NetBSD/xsrc mInJ8Z7external/mit/xdm/dist/config Xservers.ws.in

   restore change lost in Xservers.ws.cpp -> Xservers.ws.in rename:

   http://mail-index.netbsd.org/source-changes/2012/02/18/msg031930.html

   Add -noretro as default server arg in configuration files where we are
   sure the user will get a visible window "soon".
   The sole reason we backed out the "retro" change from upstream
   was to avoid an empty black screen after manualy starting just "X". With
   these preconfigured startup mehtods, this confusion can not happen.


   pointed out by jmcneill.

NetBSD/xsrc 8RUM3WLexternal/mit/libvdpau/dist/src vdpau_wrapper.c mesa_dri2.c

   merge this change from maya@:

   commit 4fa18f04dce5333189004834c1183d7a14ee0ef5
   Author: Maya Rashish <maya at NetBSD.org>
   Date:   Sun Feb 24 09:32:11 2019 +0200

       Don't warn (-Werror) about secure_getenv, use getenv_wrapper.

       Does the same thing for netbsd.

NetBSD/xsrc S6Ep7Srexternal/mit/MesaLib/src/arch/i386 matypes.h, external/mit/MesaLib/src/arch/x86_64 matypes.h

   generated files for mesa 18.3.4.

   this work from maya@ via this github commit:

   commit 9eeee3fcb33a84ebc1653c032f57e7193b7b7236
   Author: Maya Rashish <maya at NetBSD.org>
   Date:   Sat Feb 23 23:14:48 2019 +0200

       Generated files for mesa 18.3.4

NetBSD/xsrc 1CZNVjkexternal/mit/MesaLib/dist/src/gallium/auxiliary/indices u_indices_gen.c, external/mit/MesaLib/dist/src/mapi/glapi glapi_x86-64.S glapi_mapi_tmp.h

   merge Mesa 18.3.4.

   this work is mostly from maya@ with a little help from myself
   via these github commits:


   commit 57df9d9b59df14fd6ac8e30832ce4f29572a33c0
   Author: coypu <coypu at sdf.org>
   Date:   Mon Mar 4 12:24:37 2019 +0200

       Make GCC happier about prototype, include right header for __HAVE_ATOMIC64_OPS

   commit 93c2f416aa316cc3d0665661c9f927f6949cdd37
   Author: coypu <coypu at sdf.org>
   Date:   Mon Mar 4 12:16:56 2019 +0200

       Make the u_atomic.c fallback locked 64bit atomics more suited

       for the netbsd case: we are using __GNUC__ compilers, but without
       libatomic. so we are emitting the __GNUC__ names.

       Use __HAVE_ATOMIC64_OPS which is the netbsd name for this condition
       (we don't run configure)

   commit 84c2bf2f622f8a78f68ad1ca35b90bb991bdaab0

    [70 lines not shown]

NetBSD/xsrc eozcmkbexternal/mit/MesaLib/dist/src/amd/addrlib/core addrlib1.cpp addrlib2.cpp, external/mit/MesaLib/dist/src/gallium/drivers/swr/rasterizer/core format_traits.h pa_avx.cpp

   Initial revision

NetBSD/xsrc r12jo1Nexternal/mit/MesaLib/dist/src/compiler/nir nir_opt_algebraic.c, external/mit/MesaLib/dist/src/gallium/auxiliary/util u_format_table.c

   from maya:

   Import mesa 18.3.4.

   Mesa 18.3.4 implements the OpenGL 4.5 API.
   Some drivers don't support all the features required in OpenGL 4.5.

NetBSD/xsrc upxqvu3external/mit/libvdpau/dist configure ltmain.sh, external/mit/libvdpau/dist/include/vdpau vdpau.h

   initial import of libvdpau-1.1.1

NetBSD/xsrc dbCHIKcexternal/mit/fontconfig/dist/fc-cache fc-cache.c

   fix merge botch in previous.

NetBSD/xsrc 75PqoeRexternal/mit/MesaLib.old/dist configure, external/mit/MesaLib.old/src/gallium/auxiliary u_format_table.c

   Initial revision

NetBSD/xsrc 30QwbN2external/mit/xf86-video-amdgpu/dist README, external/mit/xf86-video-amdgpu/include config.h

   merge xf86-video-amdgpu 19.0.0.

NetBSD/xsrc Az3334lexternal/mit/xf86-video-amdgpu/dist ChangeLog, external/mit/xf86-video-amdgpu/dist/src drmmode_display.c amdgpu_kms.c

   initial import of xf86-video-amdgpu-19.0.0

NetBSD/xsrc o4Z0PeHexternal/mit/xorg-server.old/include xorg-config.h dix-config.h

   turn on execinfo support.

NetBSD/xsrc XRYQHshexternal/mit/fontconfig/include fcaliastail.h fcalias.h

   regen for fontconfig 2.13.1.

NetBSD/xsrc bJI7MOTexternal/mit/fontconfig/dist/src fcfreetype.c fccfg.c

   merge fontconfig 2.13.1.

NetBSD/xsrc RSaD7Txexternal/mit/fontconfig/dist configure ABOUT-NLS, external/mit/fontconfig/dist/doc fontconfig-devel.txt fontconfig-user.txt

   initial import of fontconfig-2.13.1

NetBSD/xsrc iZXXubGexternal/bsd/libuuid_ul/dist gen_uuid.c unparse.c

   remove some unnecessary code:
   - win32
   - other comapt code
   - uuid daemon code
   - TLS code
   - unused functions and features

NetBSD/xsrc 3zKvi6Xexternal/bsd/libuuid_ul/dist gen_uuid.c uuid.h

   import a small portion of util-linux's "libuuid".  this is needed for
   the new fontconfig which uses these APIs internally.  we'll rename
   the symbols and they aren't exported by fontconfig.so anyway.

   this is necessary because libuuid's API conflicts with netbsd libc
   uuid API while being not really simple to shim or provide compat for.